Développement

Quelques notes pour répondre à des problématiques rencontrées au travail.

OS X Yosemite : downgrade Java de 1.8 à 1.6

Supprimer la version de Java actuelle, la 1.8.0_40 dans mon cas :

sudo rm -rf /Library/Java/JavaVirtualMachines/jdk1.8.0_40.jdk

Télécharger et installer Java 1.6 depuis le support Apple.

Réactiver le module web en suivant les instructions du support Apple :

sudo mkdir -p /Library/Internet\ Plug-Ins/disabled
sudo mv /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin /Library/Internet\ Plug-Ins/disabled
sudo ln -sf /System/Library/Java/Support/Deploy.bundle/Contents/Resources/JavaPlugin2_NPAPI.plugin /Library/Internet\ Plug-Ins/JavaAppletPlugin.plugin
sudo ln -sf /System/Library/Frameworks/JavaVM.framework/Commands/javaws /usr/bin/javaws

Vérifier que la version de Java est bien 1.6 :

Publié le 25/03/2015
dans la catégorie Développement.
Dernière mise à jour le 26/03/2015.

Tags : java mac osx yosemite

Commentaires

Poster un commentaire

Votre adresse e-mail ne sera pas affichée sur le site.